Call forwarding and Inbound Voicemail Issues

Incident Report for Kixie

Resolved

We have implemented changes to resolve the issues with forwarding calls, voicemails, and agents getting stuck in an on-call status.
Posted Mar 30, 2026 - 20:48 PDT

Update

New calls will now be forwarded, and voicemails can be left by inbound callers. A final fix will be released at 8:00 PM PDT.
Posted Mar 30, 2026 - 17:07 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 30, 2026 - 16:37 PDT

Update

We have noticed some agents getting stuck in an "On Call" status.
Posted Mar 30, 2026 - 16:19 PDT

Investigating

We have noticed some issues with call forwarding not working and inbound voicemails not being received.
Posted Mar 30, 2026 - 15:11 PDT
This incident affected: PowerCall (Call Functionality) and Inbound Calling (Ring Group Functionality, IVR Functionality, Queue Functionality).