The incident was caused by an AWS service disruption affecting CloudFront DNS resolution and configuration propagation. AWS has resolved the outage, and our systems have returned to normal operational levels.
Posted Feb 10, 2026 - 20:25 PST
Update
We are continuing to monitor for any further issues.
Posted Feb 10, 2026 - 14:49 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 10, 2026 - 14:48 PST
Identified
The issue has been identified as caused by an AWS outage, we're currently working alongside their team to restore service.
Posted Feb 10, 2026 - 13:16 PST
Update
We are continuing to investigate this issue.
Posted Feb 10, 2026 - 12:46 PST
Update
We are continuing to investigate this issue.
Posted Feb 10, 2026 - 12:43 PST
Investigating
We are currently investigating this issue.
Posted Feb 10, 2026 - 12:36 PST
This incident affected: PowerCall (Call Functionality, SMS Functionality, Click to Call) and Dashboard (Manage Teams, Manage Ring Groups, Manage IVRs, Manage Queues, Manage Dispositions, Manage Cadences, Manage Powerlists, Manage Agents, Manage Account, Manage Numbers, Manage Billing).