PowerCall Performance Degradation

Incident Report for Kixie

Identified

The issue has been identified and a fix is being implemented.
Posted Nov 14, 2025 - 15:53 PST

Investigating

Some PowerCall performance may currently be degraded, such as call history, SMS history, call recordings, and contact data population. Our team is actively investigating the root cause.
Posted Nov 14, 2025 - 12:10 PST
This incident affects: Reporting (Call History, SMS History), Pipedrive (Pipedrive Call Logging, Pipedrive SMS Logging), Hubspot (Hubspot Call Logging, Hubspot SMS Logging), Salesforce (Salesforce Call Logging, Salesforce SMS Logging), Zoho (Zoho Call Logging, Zoho SMS Logging), and GoHighLevel (GoHighLevel Call Logging, GoHighLevel SMS Logging).