North America Database Server Issue
Incident Report for kixie
Resolved
Our North America Servers are fully rebooted
Posted Jul 10, 2020 - 10:02 PDT
Update
The servers are rebooting
Posted Jul 10, 2020 - 10:00 PDT
Identified
We are currently experiencing and issue with our North American database server. Our team is working rapidly to resolve it.
Posted Jul 10, 2020 - 09:51 PDT
This incident affected: PowerCall Chrome Extension, Account Dashboard, and Integration API.