Server Delays
Incident Report for kixie
Resolved
Our servers are back up to 100% speed and all operations should be normal now.
Posted Jan 14, 2020 - 10:24 PST
Identified
We are currently investigating server delays that are causing delays in dialing and dashboard access
Posted Jan 14, 2020 - 09:54 PST
This incident affected: PowerCall Chrome Extension, Account Dashboard, and Integration API.