Issues with Dialing, SMS, Dashboard

Incident Report for Kixie

Resolved

This incident has been resolved.
Posted Mar 28, 2023 - 16:02 PDT

Update

We are continuing to work on a fix for this issue.
Posted Mar 28, 2023 - 15:55 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 28, 2023 - 15:51 PDT

Investigating

We are currently resolving the issue.
Posted Mar 28, 2023 - 15:51 PDT
This incident affected: PowerCall (Call Functionality).