SMS History in PowerCall Issue
Incident Report for kixie
Resolved
This issues has been resolved
Posted May 26, 2020 - 10:13 PDT
Identified
We are working on getting the SMS history back online
Posted May 26, 2020 - 09:18 PDT
This incident affected: PowerCall Chrome Extension.