Updating Call History and Reporting
Incident Report for kixie
Resolved
Call history and reporting are back up.
Posted Dec 10, 2019 - 16:29 PST
Update
We are continuing to work on a fix for this issue.
Posted Dec 10, 2019 - 14:46 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 10, 2019 - 14:42 PST
Investigating
We are currently making updates to the call history and reporting.
Posted Dec 10, 2019 - 14:42 PST
This incident affected: PowerCall Chrome Extension and Account Dashboard.