Server Load Issue
Incident Report for kixie
Resolved
Sever traffic has been stable for 1 hour. We are resolving this ticket and will continue closely monitoring.

Moving forward, we are working on processes to improve server stability and uptime.
Posted May 31, 2018 - 11:57 PDT
Monitoring
Our servers are back up to 100%. We identified a flood of traffic and have blocked it.

If you are still experiencing issues, please close out Kixie and re-open it.
Posted May 31, 2018 - 11:46 PDT
Update
Currently, users can continue dialing, but some calls may not go through, so the call would have to be retried
Posted May 31, 2018 - 11:10 PDT
Identified
Significant traffic spikes have caused degraded performance on our servers. We are working rapidly to identify the cause of the problem and resolve it.
Posted May 31, 2018 - 11:01 PDT
This incident affected: PowerCall Chrome Extension, Account Dashboard, and Desk Phone Devices.