Amazon AWS DNS issues
Incident Report for kixie
Resolved
If you see Kixie your dialer "offline", a reload of the dialer should solve the issue.
Posted Oct 22, 2019 - 16:04 PDT
Update
Update from Amazon: We are investigating reports of occasional DNS resolution errors. The AWS DNS servers are currently under a DDoS attack. Our DDoS mitigations are absorbing the vast majority of this traffic, but these mitigations are also flagging some legitimate customer queries at this time. We are actively working on additional mitigations, as well as tracking down the source of the attack to shut it down.
Posted Oct 22, 2019 - 16:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 22, 2019 - 15:06 PDT
Identified
Amazon AWS is currently having issues with DNS which is causing the Kixie dialer to sporadically go offline. Amazon is actively working on resolving the issue

You can view Amazon status here: https://status.aws.amazon.com/
Posted Oct 22, 2019 - 12:51 PDT
This incident affected: PowerCall Chrome Extension and Desk Phone Devices.