Outbound SMS issue to North American Phone Numbers
Incident Report for kixie
Resolved
This incident has been resolved.
Posted Jul 14, 2020 - 19:15 PDT
Investigating
We are seeing a delay with outbound SMS getting delivered to North American phone numbers. We are currently investigating this issue.
Posted Jul 14, 2020 - 18:54 PDT
This incident affected: PowerCall Chrome Extension and Voice and SMS Automation.