Degraded Performance [PowerCall and Dashboard]
Incident Report for kixie
Resolved
This incident has been resolved.
Posted May 26, 2020 - 16:03 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2020 - 11:56 PDT
Identified
We are continuing to see performance delays with making and receiving calls. Calls may take long than normal to dial out/connect.

IMPORTANT NOTE - once the calls dials out, everything will work as normal. Please do not end the call prematurely.
Posted May 26, 2020 - 11:12 PDT
This incident affected: PowerCall Chrome Extension and Account Dashboard.