Inbound calls to UK numbers
Incident Report for kixie
Resolved
Our carrier partner has resolved the issue.
Posted Mar 18, 2019 - 15:15 PDT
Identified
One of our telecom carriers is observing major inbound voice & SMS call failures towards United Kingdom phone numbers. A large segment of phone numbers may experience call failures.

We're actively working with our carrier partner to get this issue resolved as soon as possible.
Posted Mar 18, 2019 - 12:03 PDT