Issues with PowerDialer Freezing
Incident Report for Kixie
Resolved
This incident has been resolved. Kixie Powercall is fully operational at this time. Thank you for your patience while our engineering team investigated this!
Posted Aug 16, 2023 - 11:54 PDT
Investigating
Our team is currently investigating reports of degraded performance and freezing while using the PowerDialer feature of Kixie PowerCall. We are actively investigating this situation, and we will provide any updates as we receive them!
Posted Aug 16, 2023 - 10:40 PDT
This incident affected: Powerlists (Powerlist Functionality).