Intermittent call failures to one of our carriers
Incident Report for kixie
Resolved
This incident has been resolved.
Posted Jan 24, 2019 - 13:46 PST
Identified
We have identified intermittent call failures to one of our carriers and are working with them to resolve it. It is sporadically affecting some calls.
Posted Jan 24, 2019 - 13:31 PST
This incident affected: PowerCall Chrome Extension and Desk Phone Devices.