Server Delays
Incident Report for kixie
Resolved
This incident has been resolved.
Posted Sep 17, 2019 - 10:33 PDT
Monitoring
Our team has implemented a fix and will continue monitoring the issue closely.
Posted Sep 17, 2019 - 10:28 PDT
Identified
We are experiencing server and database spikes that are causing calls to be delayed or not go through at all. Our team is working on resolving the issue.
Posted Sep 17, 2019 - 10:23 PDT
Update
We are continuing to investigate this issue.
Posted Sep 17, 2019 - 10:17 PDT
Investigating
We are currently experiencing server delays and our entire team is investigating.
Posted Sep 17, 2019 - 10:16 PDT
This incident affected: PowerCall Chrome Extension, Account Dashboard, Integration API, and Desk Phone Devices.