PowerDialer and Click to Call Experiencing Degraded Performance
Incident Report for Kixie
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 09:19 PDT
Update
We are continuing to investigate this issue.
Posted Apr 24, 2024 - 09:18 PDT
Investigating
Powerdialer and Click to Call are currently experiencing degraded performance through a prolonged delay in the execution of calls. We are observing that manual calls are currently functioning.
Posted Apr 24, 2024 - 09:10 PDT
This incident affected: Call & SMS Functionality.