We are experiencing Amazon Web Server issues.
Incident Report for kixie
Resolved
Our Amazon servers are back to 100% speed.
Posted Jan 31, 2020 - 08:58 PST
Update
We are seeing delays of up to 30 seconds for phone calls to go through. Our team is working rapidly to return things to normal speed.
Posted Jan 31, 2020 - 08:37 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 31, 2020 - 08:25 PST
This incident affected: PowerCall Chrome Extension, Account Dashboard, and Desk Phone Devices.