SMS Disabled in PowerCall
Incident Report for kixie
Resolved
This incident has been resolved.
Posted May 26, 2020 - 14:20 PDT
Identified
We have turned off SMS in PowerCall for the short term. You can login below to send SMS

https://app.kixie.com/sign-in.html
Posted May 26, 2020 - 12:13 PDT
This incident affected: PowerCall Chrome Extension.