Partially degraded "Queued" and "Deferred" contact counts performance for PowerLists in PowerCall

Incident Report for Kixie

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 18:45 PDT

Investigating

Related to this morning's outage, "Queued" and "Deferred" counts for contacts in PowerLists in PowerCall may not be consistently accurate. Team is investigating a solution.
Posted Aug 06, 2025 - 10:14 PDT
This incident affected: Outbound Calling (Powerlist Functionality).