Database Connection Errors

Incident Report for Kixie

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:54 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Oct 20, 2025 - 15:36 PDT

Investigating

We are currently investigating an issue that may be impacting some customers. We are trying to determine if it is related to a current AWS outage.
Posted Oct 20, 2025 - 09:57 PDT
This incident affected: PowerCall (Call Functionality, SMS Functionality) and Dashboard (Manage Teams, Manage Ring Groups, Manage IVRs, Manage Queues, Manage Dispositions, Manage Cadences, Manage Powerlists, Manage Agents, Manage Account, Manage Numbers, Manage Billing).