Issues with PowerList and PowerDialer
Incident Report for Kixie
Resolved
This incident has been resolved. The PowerDialer is fully operational at this time. Thank you for your patience while our engineering team investigated this!
Posted Nov 14, 2023 - 10:11 PST
Investigating
Our team is currently investigating reports of degraded performance when uploading a PowerList and calling out using the PowerDialer. We are actively investigating this situation, and we will update you as soon as possible.
Posted Nov 14, 2023 - 07:37 PST
This incident affected: Call & SMS Functionality and Powerlists (Powerlist Functionality).