Some servers are experiencing high load and we are switching over to another set.
Incident Report for Kixie
Resolved
This incident has been resolved.
Posted Feb 25, 2021 - 09:11 PST
Investigating
We are currently investigating this issue.
Posted Feb 25, 2021 - 09:10 PST
This incident affected: Call & SMS Functionality.